Weekly Learn Log: Apache 2.4, SSL Vulnerabilities, Regex

3/21

  • Apache 2.4: no more order allow,deny followed by allow from all. Now
    it’s Require all granted.

3/22

3/23

  • PHP short_open_tag is off by default in the Ubuntu distro of PHP 5.5.
  • Add it to your apache conf to enable (or NGINX equivalent). Don’t
    use .htaccess if you don’t have to.
    php_flag short_open_tag 1

3/25

  • PCRE (perl compatible regular expressions) supports POSIX character classes.
    Details here
  • Example in PHP: This strips out non-printable characters:
    preg_replace('/[[:^print:]]/', '', $data);

3/26

  • git request-pull is a low level equivalent of a pull request on GitHub
    or other service. I don’t think it’s useful if using a service or web
    interface for your central repo administration.

You may also like

Leave a Reply

Your email address will not be published. Required fields are marked *